Power Apps Standards: Naming Conventions

Power Apps Standards: Naming Conventions
Table Of Contents:
β€’ Screen Names
β€’ Control Names
β€’ Variable Names
β€’ Collection Names
β€’ Datasource Table Names




Screen Names

A screen name should clearly describe its purpose in 2-3 words ending with word β€œScreen.”  Use proper-case.   A screen-reader will speak the screen name to visually-impaired users when the screen loads.

Good ExamplesBad ExamplesBad Reason
Appointments ScreenAppointmentsMissing the word β€˜Screen’
Order Form ScreenOrderFormScreenNot friendly to a screen reader
Collect Signature ScreenscrCollectSignatureNot friendly to a screen reader




Control Names

A control name should show the control-type, the purpose and the screen.  Use camel-case and underscores for spacing.  For example, the control named txt_OrderForm_FirstName is a text input that captures first name on the app’s Order Form Screen. 

Good ExamplesBad ExamplesBad Reason
drp_NewEmployee_DepartmentdrpDepartmentNewEmployeeNo spacing
btn_OrderForm_Submitbtn_Submit_OrderFormWrong order
gal_Home_Appointmentsgly_Home AppointmentsNon-standard control prefix



A list of standard control prefixes can be found below.

Control Prefix
3D Object 3do
Add Picture pic
Address Input add
Audio aud
Barcode Scanner bar
Button btn
Camera Control cam
Canvas cvs
Card dtc
Charts chr
Check Box chk
Collection col
Container con
Combo Box cmb
Component cmp
Date Picker dte
Drop Down drp
Export exp
Form frm
Gallery gal
Group grp
HTML Text htm
Icon ico
Image img
Import imp
Label lbl
List Box lst
Map map
Measuring Camera mcm
Microphone mic
Microsoft Stream str
PDF Viewer pdf
Pen Input pen
Power BI Tile pbi
Radio rad
Rating rtg
Rich Text Editor rte
Shapes shp
Slider sld
Table tbl
Text Input txt
Timer tmr
Toggle tgl
Video vid




Variable Names

A variable name should show the scope of the variable and its purpose. Use camel-case with no spaces between each word. For example, the variable gblUserEmail is a global variable which holds the current user’s email address.

Good ExamplesBad ExamplesBad Reason
gblUserCurrentUserCurrentNo scope
locPacksInBoxQuantityLoc_Packs_In_Box_QuantityImproper capitalization and spacing
LocIsLoadinglocBoolLoadingDo not use data types in variable names
varWorkdaysDuringVacationvarWorkdaysNot descriptive enough




Collection Names

A collection name should contain the original datasource and describe its purpose. Use camel-case with no spaces between each word.  For example, the collection colDvInvoices is a collection of invoices from Dataverse.


Good ExamplesBad ExamplesBad Reason
colSpEmployeescolEmployeesNo datasource
colDvSalesLeadscoldv_salesleadsImproper capitalization and spacing
colNavigationMenuNavigationMenuDo no use data types in variable names



A standard list of datasource abbreviations can be found below:

Original DatasourceAbbreviation
DataverseDv
SharePointSp
SQLSql
SalesforceSf
None (created in-app)(none)




Datasource Table Names

A datasource created by the developer should have 1-3 words to describe its purpose.  Use the singluar form of the word and proper-case.  Be as concise and clear about the purpose of the datasource as possible.

Good ExamplesBad ExamplesBad Reason
EmployeeEmpAbbreviation instead of full word
Construction ProjectProjectsToo general, what type of projects?
Repair OrderRepairOrdersNo spacing, plural





Questions?

If you have any questions about Power Apps Standards: Naming Conventions please leave a message in the comments section below. You can post using your email address and are not required to create an account to join the discussion.

Subscribe
Notify of
guest

26 Comments
Oldest
Newest
Inline Feedbacks
View all comments
David Wyatt
David Wyatt
1 year ago

Interesting read thank you, though little confused around your thoughts on data types in variable naming. As you say it should (which I totally agree with) but then ‘locBoolLoading’ is bad because it includes data type?

David Wyatt
David Wyatt
1 year ago

Thanks for clarity, interesting choice not too. I like a structure of scope-type-description as easier for intellisense (as I can filter the variables down as I type)

Rex
Rex
9 months ago

I think I agree with David and your typo rather than you (unusually) Matthew. Variable types can vary so greatly (string, record, table etc.) that their type in their name assists readability imho. Be interested to know what you think is the downside.

Geraint
Geraint
2 months ago

I think it’s hard to stand by that logic, when the other conventions are btn_OrderForm_Submit and colDvSalesLeads but I agree it’s easier to leave it out of variable names than controls (e.g. multiple cases like lblName, txtName).

Reiner Knudsen
Reiner Knudsen
1 year ago

I saw some MS document somewhere and found it very confusing – and hard to use. These instructions are much better. I will add this to my ressource collection πŸ™‚

Felix Gieseke
Felix Gieseke
1 year ago

Hi Matthew, great work on the guide!
I’d like to propose a minor improvement for the control naming. I would add the control type as suffix. Then you have the order of the name parts by their relevance for most use cases.
A common scenario is to have a data field “FirstName”. Then on the form you have an input control for that field together with a label. If you use OrderForm_FirstName_txt and OrderForm_FirstName_lbl as control names you see on the first glance, that those two belong together. Especially if you order the controls on the screen/form by name.

Hjalmar Otto FjΓΈsne
Hjalmar Otto FjΓΈsne
1 year ago

Excellent guide, and site for that matter!

I’ve tried using the official whitepaper for some time and find it very useful. I notice that you have introduced an underscore after the prefix for control names, which is not the case in the official whitepaper, can you share the reasoning behind this convention?

Hjalmar Otto FjΓΈsne
Hjalmar Otto FjΓΈsne
1 year ago

I see your point on visibility, but I’m a bit worried that introducing another convention (snake_case combined with camelCase and or PascalCase) adds more complexity than what its worth. Another thing is that pascal, camel, snake (and so on) case are familiar convention patterns pro developers are familiar with, and that pro developers in fusion teams may find it a bit too unconventional πŸ™‚

Eric
Eric
11 months ago

Do you have some experience to standard environment variable and connection reference in solution?

Adam Middleton
Adam Middleton
10 months ago

Great guide / standards.
I especially like the _ between segments. It keeps things visually clear and allows simple processing to extract if needed.

Lynn Brown
Lynn Brown
8 months ago

Why do you have controls using underscore between names, yet everything else is CamelCase with one word? It would seem to me that you’d want them all the same. Would the Variable be better started with var?

Buse Doctor
Buse Doctor
7 months ago

I’m a non tech learner, already in the Microsoft Power Up program. Having challenges creating my first app. The major challenge is the function, controls and variables, making the icons I select do what is required. I need elaborate help, may be resources that can help me enter appropriate command functions. Really appreciate Mathew Devaney and co, for a nice job here.

Buse Doctor
Buse Doctor
7 months ago

Really appreciate. Thank you.

Kim Buske
5 months ago

Great collection of standards!

Just a minor thing:
Regarding Datasource Table names you recommend using Singular form.
Shouldn’t it be “Construction Project” and “Repair Order”?

Thanks for delivering such good advice! πŸ™‚

Thien
Thien
4 months ago

With named formulas coming soon. What would you recommend as a naming conventions for it? Should it still be gbl?

Thank you and great advice!

Last edited 4 months ago by Thien
Martin Swinkels
3 months ago

Hi Matthew,

I’m a big fan of your work and really appreciate your contribution to the community. In my Power Apps projects, I often rely on your blog posts, they are brilliant.

I do have a suggestion for the β€œNaming Conventions”, especially for Control Names. In my humble opinion, it would be easier to follow the following order; control-type, the purpose and screen. Please let me explain my thoughts.

I’ve created a Power Apps Template (probably like many others) as an accelerator including a template screen. This way new screens can easily be created by duplicating it from this template screen. While duplicating this template the standard behavior of Power Apps is to add a suffix to all controls on the new screen e.g.: β€œ_1”.

Let’s say my template is named β€œTemplate Screen” which has a control named β€œcon_Template_MainContext”, the naming for the new controls on the new screen would be something like:

β€œcon_Template_MainContext_1”

With 20 (or more) predefined controls on a template screen, you now must manually change all the control names, which is a tedious amount of work. Find/replace will be tricky because you don’t want to replace the screen name β€œ_template_” of the original template screen itself and the controls on it.

Furthermore, you must use the find/replace twice, because you also have to remove the automatically added prefix β€œ_1” for all the controls as well.

Following my suggested order like β€œcon_MainContext_Template” you will get new control names like:

β€œcon_MainContext_Template_1”

This makes it much easier to use the find/replace option; you just replace β€œ_Template_1” with a new screen name like: β€œ_ScreenName”.

In my experience it is also easier to read (find) the purpose of a control most left in the naming. Try reading the purpose of the controls in the picture. Do you notice that you skip the screen prefix part while scanning the controls?

In my opinion the suffix of the screen is less important, its main job is to stay out of conflict with duplicate names.

Is this something to consider changing in your guidelines?
Thanks in advance for your reply.

2023-11-30_12-52-45.png